Help get this topic noticed by sharing it on Twitter, Facebook, or email.

AHCI mode in BIOS makes nero think DVD and blurray burner is only CD burner

I just purchased two 256GB SSD (solid state disk) drives (samsung pro 850) for my windows 7 and linux mint computers (identical hardware).

To support SSD properly (or at all with some SSDs), many sources said the BIOS must be set to AHCI mode, not IDE mode. And so I changed IDE to AHCI, then proceeded to install 64-bit windows7 on my new SSD from the windows7 installation DVD. Then I installed most of my usual applications.

I downloaded and installed nero platinum 2015 on the SSD. But when I went to burn an 2GB ISO file that was meant to burn on DVD, nero burner would not burn the DVD and reported the drive is only a CD drive! Yet both my burner drives are bluray burners, and I have been burning and reading/playing DVDs and bluray disks for about two years on those drives already (previously with nero v11, which is still on the old boot drive, which I can still boot to run nero v11). So, this problem exists with both v11 (2011) and v15 (2015).

Note that the nero "infotool" reports both drives support pretty much every type of CD and DVR and BD except "Mount Rainier".

Also note that I was able to burn DVDs and bluray with the free gizmo application, so obviously the drives are 100% fine, and the drivers are 100% fine. What is apparently NOT fine is nero software when the BIOS is set to AHCI mode instead of IDE mode.

I confirm this by switching the BIOS back to IDE and booting up onto my previous windows7 boot drive. Now both nero v11 and v15 see both drives as capable of burning DVDs and blurays.

I would NEVER have figured out that was the problem, except that was the ONLY change I made, and so after hours of trying things I finally tried switching that one change back... and presto.

This may solve the problem for others, but not for me. Many sources say it is BAD for SSDs to run the BIOS in IDE mode instead of AHCI mode.

So how can I fix this problem for both v11 and v15, so when I switch back to AHCI mode as I must (for the sake of my expensive new SSD), I can burn DVDs and blurays?

PS: As usual, everything worked without problems in my linux system. Of course, it doesn't run nero software either. But increasingly as time goes by, I've noticed linux has far fewer problems than windoze.
1 person has
this problem
+1
Reply