AVCHD DVD async

I imported an MP4, 1920x1080, 2 hour video (AAC stereo audio) into Nero Video 2014 and twice tried to make a AVCHD DVD but twice after about 7 hours of transcoding the output AVCHD video and audio are out of sync.

In the beginning of the output AVCHD video the audio and video are in sync but as the video progresses the async becomes steadily worse.

Thanks.
4 people have
this problem
+1
Reply
  • Hi nbdg223-

    There's a few threads on this issue. Normally, sync problems are caused by dropped frames which aren't visible during playback. I usually request that people try recoding to mpeg-4 to try to alleviate the problem. I saw that you had a question on that in a new thread and I responded there.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Hi Wither,

    Thanks so much for your replies in this and in my other threads.

    I managed to make a AVCHD DVD - this time with audio and video in sync throughout the whole video - by first recoding the MP4 file to MP4 in Nero Recode (perhaps Recode repaired it somehow?), then importing the recoded MP4 video into Nero Video 2014, adding chapters, and the output AVCHD DVD is perfect.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Over the years, I've found that recoding with Recode will remux, to some extent, problematic files. For really tough ones, we recommend something TsMuxeR or others.

    I'm glad you got a satisfactory result.

    Enjoy!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • In Nero Video 2015 can you now make a synchronized AVCHD DVD without having to first import the MP4 file into Recode and recode to MP4 and then import the output MP4 from Recode into Nero Video 2015 ? (this did not always work in Nero Video 2014).
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Key thing is the source clip. If this is out of sync Nero Video cannot put it in sync again.
    Can you share your source clip? Use Nero BackItUp Online Storage to share.
    https://my.nerobackitup.com/register
    • Thanks for replying, Video Doc.

      It's the conversions of MPEG2-TS files with AAC-LATM or AC3 audio (with A/V in sync) that I find usually cause async in Nero Recode 2014 and Nero Video 2014. However these same MPEG2-TS files can be converted to say MP4 in XMedia Recode correctly without any async.

      Source:

      Format : MPEG-TS
      File size : 16.4 MiB
      Duration : 105ms
      Overall bit rate : 2 681 Kbps

      Video
      ID : 101 (0x65)
      Menu ID : 40960 (0xA000)
      Format : AVC
      Format/Info : Advanced Video Codec
      Codec ID : 27

      Audio
      ID : 102 (0x66)
      Menu ID : 40960 (0xA000)
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format profile : LC
      Muxing mode : LATM
      Codec ID : 17
      Duration : 105ms
      Channel(s) : 2 channels
      Channel positions : Front: L R
      Sampling rate : 48.0 KHz
      Compression mode : Lossy
      Delay relative to video : -730ms
      Language : English
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • This reply was removed on 2015-05-31.
    see the change log
  • 1
    nbdg223,

    In a previous post, perhaps deleted or modified, you said, "Maybe OmegaTester was able to reproduce the async starting later in the output video and becoming steadily worse in one of his many threads where he was able to reproduce many async problems in Nero Recode 2014 and Nero Video 2014. I'd like to upgrade to Nero 2015 if these async problems don't occur in Nero 2015. At present I have to use the freeware 'XMedia Recode' which doesn't introduce async in the output files like Nero Recode 2014 and Nero Video 2014 do in some of the output files."

    When the recent "hotfix" files for Nero Recode were posted, the very first check I did had sync problems just as before. I pointed that out in topic Smart render not working.

    In respoonse, three weeks ago on May 12th at 17:03, Video Doc said, "I hope to get back to you with some results by end of this week."

    I asked for some feedback one week ago, on May 26th at 15:52. Nothing has been forthcoming.

    Please note that a simple procedure is outlined in that post enabling a sync issue to be demonstrated using only Nero files and procedures. It will be nearly a year since I reported the bug. I have never received even an acknowledgement that the problem has been replicated via email or in the recent "dialogue" with Video Doc. They just don't seem interested. It is interesting to me that in the meantime, Video Doc has been all over the forum asking users to upload files for Nero to check out. In most cases, as in yours, the posts are very old and the users have probably moved on to other software.

    It may be of interest to you that XMedia Recode does a fine job on the referenced issue. This is another way that the problem can be worked around!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • EMPLOYEE
    I’m confident
    Hi Omega Tester.

    We are working on the issues, and I am in close cooperation with or QA, indeed. In fact understanding the root cause is not as easy as it may seem.

    For all the entries in the forum where I asked for source files I have a good reason for doing so, although or even just because some of these threads are maybe one year old without an actual clarification of the problem. So going back to the initial problem description and trying to reproduce the issues in our QA just led to the result that these issues are just not reproducible without the sources files. Only an analysis of the source file can help to get a clear picture.

    When talking about A/V out of sync it is really difficult to compare one case with another. And in this respect it is also not really problem solving to have cross-references in many threads like 'I have the same problem ...' which in essence would rather be somethig like comparing apples and oranges.

    I would appreciate if you acknowledged that we are really trying to solve the known issues. It would help if the negative tone in some of these threads would have a little less sharper voice and give us a second chance. We fully appreciate your support over all these years and I guess with your reputation in this forum you could really be an ambassador for the this approach.

    I will also reply to the other thread again (Smartrender not working).
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Hi Video Doc,

    Here is the download link for the BBC News HD UK Weather Forecast MPEG2-TS SOURCE FILE:
    http://nerobackitup.pogoplug.com/s/gU...

    Here is the download link for the BBC News HD UK Weather Forecast RECODE 2014 OUTPUT MP4 ASYNC FILE:
    http://nerobackitup.pogoplug.com/s/Nk...

    The source file was converted by Nero Recode 2014 to MP4 and introduced A/V async in the output file.

    Thanks.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Interesting-

    I created a AVCHD-DVD project with the first file in Nero Video 2014 and burned it to disc (no menu). It is not out of synch. However, this is just a 2 minute video. Usually synch problems occur with longer videos.
    • view 4 more comments
    • If Nero 2012, Nero 2014 and Nero 2015 are not compatible with Windows Media Player then Nero should advertise this fact.

      The output MP4 file made by the freeware XMedia Recode has no async in Windows Media Player.
    • I saw in the other thread regarding 'Smart rendering' that Video Doc stated: "In our internal testing shows that we have an issue with AC3 pass through in Nero Recode leading to out of sync issues. We are working on that." The MPEG2-TS source file I linked above has AC3 audio and the async occured in the Nero Recode 2014 MP4 output file.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • 1
    Some results

    The source .ts file may not be perfect:

    1. It cannot be imported into tsMuxer.
    2. There is a "glitch" at about 2m02s evident when played in Nero MediaHome. The "glitch" is not evident when using VLC Player, VideoGo (trial), or PotPlayer.

    About conversions to .mp4:

    1. If done with Nero 2014 Recode, the "glitch" occurs and the audio/video sync is lost. As mentioned by others, the entire video is out of sync when played in Windows Media Player on Windows 8.1 Pro.
    2. If done with Nero 2015 Recode (including the recent sync "hitfix"), the "glitch" occurs and the audio/video sync is regained. As mentioned by others, the entire video is out of sync when played in Windows Media Player on Windows 8.1 Pro.
    3. Using various freeware programs, there is no "glitch" and the A/V sync is fine regardless of which player is used.

    As a quick summary, I made a video which includes the same 10 second segment from 5 conversions to .mp4. For the curious:



    As a sidenote, what I think is an old problem arose while testing. The .ts file provided was importable into Nero 2014 Recode and then Nero 2015 Recode. Thereafter, it would not import into Nero 12, 2014, or 2105 Recode until the name was changed. This phenomenon occurs for some names, but not others!

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • One thing I overlooked is that nbdg233 question was in reference to v2015 whereas the original subject of this thread is v14. That's why I used v14 to make the DVD

    I also noticed that the .ts file has almost a 1 second delay between the audio and video when reviewed in MediaInfo. I don't know if that would have any effect on the synch problem. Afterall, TV tuners have been handling this for at least 65 years.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Hi nbdg223 (& Omega Tester).

    thanks for providing the source clips. It helped to verify the root cause and also verifies that the recently deliverd A/V Sync 'hotfix' posted in this forum solves the issue.

    The delivered .ts source file has an A/V out of sync issue at about 2m02s.

    If imported to Nero Recode 2014, the 'glitch' occurs and the audio/video out of sync remains when exported to file. As mentioned by others, the entire video is out of sync when played in Windows Media Player on Windows 8.1 Pro.

    If done with Nero Recode 2015 and Nero Video 2015 (that includes the recent A/V sync 'hotfix' posted within this forum), the A/V out of sync is gone when exporting to file.

    These are the results of our testing with Nero 2015 including the latest A/V sync hotfix:

    - Import A/V out of sync source to Nero Video 2015, play in timeline
    > A/V source out of sync occurs (expected behavior)
    - Import A/V out of sync source to Nero Recode 2015, play in Nero Recode
    > A/V source out of sync occurs (expected behavior)
    - Play A/V out of sync source in Nero MediaHome
    > A/V source out of sync occurs (expected behavior)

    - Export out of sync source .ts file to mp4 in Nero Video 2015, play back in Nero MediaHome: > A/V in sync
    - Import the exported Nero Video mp4 file to Nero Viedo 2015 or Nero Recode 2015, and play back: > A/V in sync!
    - Export out of sync source .ts file to mp4 in Nero Recode 2015, play back in Nero MediaHome > A/V in sync!
    - Import the Nero Recode exported mp4 to Nero Video 2015 or Nero Recode 2015 again and play back: > A/V in sync!

    Conclusion: the A/V sync hotfix works for all cases as expected. We will add the fix to the next public version.

    Also XMedia Recode can fix the glitch. When playing the exported mp4 by XMedia Recode in Nero MediaHome (and also other players that users mentioned), the A/V sync is gone. When importing this clip to Nero Video or Nero Recode and do playback: A/V is in sync. Export the ‘clean’ file to mp4 in Nero Video or Nero Recode A/V is in sync.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • 1
    Video Doc,

    It's difficult to know how to respond to this last declaration, but I can say for certain that most of the conclusions probably need to be reconsidered. Most important would be the statement, "the A/V sync hotfix works for all cases as expected". Low expectations?

    I will ignore any reference here to Nero Video since I have only been testing Nero Recode. My testing "shows" that the recent hotfix makes absolutely no difference - the results are the same with or without it in this instance.

    Turning now to:

    "If imported to Nero Recode 2014, the 'glitch' occurs and the audio/video out of sync remains when exported to file. As mentioned by others, the entire video is out of sync when played in Windows Media Player on Windows 8.1 Pro.

    If done with Nero Recode 2015 and Nero Video 2015 (that includes the recent A/V sync 'hotfix' posted within this forum), the A/V out of sync is gone when exporting to file.
    "

    The fact is that the sync problems evident when playing the Nero 2014 output in Windows Media Player are just as bad when playing the Nero 2015 output in Windows Media Player.

    I've prepared yet another video with the following Nero Video timeline:



    Here is the result:



    I hope that whoever is doing Nero's testing and making the conclusions has 10 minutes to review this and then take some serious time to retest! It is quite clear to me that the main "improvement" in Nero 2015 is a better handling of HW acceleration, not any hotfix?

    Yesterday, I failed to mention some testing I did with the free program YAMB. First, converting the .ts to .mp4 result in an output file that had audio but only a frozen frame of video from the end of the source file. The YAMB program also left behind a log file with a host of WARNINGs, etc. So, indeed, the source file is not perfect.

    Today, I used YAMB to "convert" the Nero .mp4 file to a new .mp4 file. That file can be viewed here:



    Conclusion: It's not just Windows Media Player that has problems interpreting the Nero output!

    I could go on and on, but seriously?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • What bothers me is that I checked the original .ts file again on this system and the only synch problem occurs at the "glitch" when playing back in NMH which is independent of the Nero version from v10 to v2015. However, the subsequent audio and video are in synch. So, it appears that what Video Doc calls a synch problem is at the glitch. The glitch doesn't appear in VLC Player but that player uses it's own set of codecs which may vary slightly from that used by other software. Recode is not intended to be a re-muxer so I don't expect it to fix every problem.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Just for S & G's, I played the original TS file in KwikMedia 1.6.16600.75...... There was no glitch shown in the file so something was changed in NMH later on.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • @ nbdg223

    let me re-iterate the problem statement.

    There are two main problems flagged within this thread: one (A) is related to the source file (.ts), the other (B) is related to the mp4 files exported by NR/NV.
    There is another issue reported by Omega Tester (C) in his latest test project. I will refer to that later.

    A) Problem 1
    The .ts source file has a glitch (dropped frames, a delay relative to video of -989ms).
    When playing back the .ts source file in Nero MediaHome, there is a glitch at 2m02s. There is no glitch in VLC, WMP, PotPlayer, and other players.
    Playing back the whole clip is in sync in all players including Nero MediaHome. The difference in Nero MediaHome is that when the glitch happens the video will pause a while but afterwards A/V is still in sync. So for this case there is no out of sync problem.

    B) Problem 2
    Import the .ts source file to NV or NR, playback in project. It is in sync but glitch happens at 2m02s. Export it to mp4.
    Re-import it and playback in timeline, it is in sync but glitch happens at 2m02s.
    Playing back the exported mp4 file is in sync with NMH, VLC, PotPlayer and other players but completely out of sync in WMP.

    Our Takeaways
    The source file is not perfect, and Nero decoder is more sensitive against glitches so that the glitch happens in Nero MediaHome and also the encoded files (in Nero Video and Nero Recode) will have the glitch as NR and NV use Nero decoder before encoding.

    Nevertheless the exported mp4 file can playback in sync in most players, whereas other players do not show the glitch. In WMP there is in fact A/V out of sync playing the exported mp4.

    As a workaround for gettimg rid of glitches you might want to use free XMedia Recode for exporting to mp4 first, then import to NR and NV.

    Regarding source files with “Delay relative to video”, the history is:
    - In N2014, with Intel and CUDA HWA, the encoded files were out of sync with any player (two reported bugs).
    - In N2014, with AMD HWA or without HWA, encoded files were in sync when played with Nero and VLC, but out of sync with WMP.
    - In N2015 we fixed the HWA related A/V out of sync issue with Intel and Nvidia GPGPUs, but did not trigger the WMP only playback out of sync. This seems to be a special problem for WMP only.

    Other than said above the hotfix version of N2015 version is NOT relevant for this special issue. Sorry for having communicated that incorrectly.

    C) @ Omega Tester (test project)

    The test project output file showed an offset in sequence 2 with about 5-6 frames while sequence 1 and 2 were in sync.

    We have done 3 initial tests with the given project design.

    1-2: All files in the timeline were MP4 files encoded from Recode, and Video track 2 was partially invisible.

    1. same project created, exported with NV 2015. Result: The audio playback with WMP and Nero is correct. No offset between 2 audio tracks.
    2. same project created this time with opacity 0, exported with NV 2015. Result: The audio playback with WMP and Nero is correct. No offset between 2 audio tracks.
    3. same project created but used .ts source clips instead of exported MP4, 50% opacity in track 2. Result:the audio playback with WMP and Nero is correct. No offset between 2 audio tracks
    http://nerobackitup.pogoplug.com/s/ru...

    So for this case we could not reprodcue the offset in sequence 2. Could it be that the mark ins for sequence 2 track 1 & 2 were slightly offset? In our understanding this would explain the problem.

    4. As stated above when just adding the .ts file to the NV timeline (no other clips in the timeline) and to NR, then export to mp4 and playback in WMP, the WMP playback is out of sync.

    We will dig deeper into this.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • It appears you verified what I said about dropped frames. You also expanded on what I questioned about the audio/video relative delays. Thanks.

    As I mentioned, I was able to play the original in KwikMedia without the glitch, but not NMH. What is the reason for that?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Hi Whiter 1,

    thanks for the reminder:
    why would KwikMedia play the original without the glitch but not NMH.
    What is the reason for that?

    I am following up on that.

    Stay tuned.
    • view 2 more comments
    • Thanks. I appreciate that you looked into it. It was just an observation on my part that I thought might help evaluating a fix for the current problem.
    • Hi Wither 1: yes indeed, looking into our source code for your reported NeroKwik Media/Nero MediaHome decoding delta helped to get a better understanding of the other bug in NR that we are dealing with right now. Thanks again.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Hello Video Doc,

    I wonder if you saw my new post in my other thread with a new (second) source file and new Nero Recode MP4 output video with A/V out-of-sync ? Here is the link:
    http://forum.nero.com/nero_eng/topics...

    Thanks.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited