Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m mighty unhappy

Download fails, unable to restart download

I purchased Nero on June 23. I had bad network problems with the download, had to restart several times. Finally received the main file, but the "contentpack" executable failed with a "network error" message about six times. On the last try for the "contentpack" my computer saved a 2k file (not the 700mb promised size); when I tried to run it produced a message that it is not a valid format for this computer (I have Win10). I tried to download again about 6 hours later and receive a message that my download rights have expired. I reported it to Cleverbridge and they refused to help. I reported it to Nero the next day and have had no response. The download link still responds that my access is denied. The download page I received upon payment said I'm eligible to download for a month. I was able to install the main product executable. How can I get the rights to download the contentpack restored?
1 person has
this problem
+1
Reply