Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

License failure - Control Center says it's ok, but I get an error when I launch

Summary: When I launch Nero 11 or any of its components, I get the message that it is non-licensed use. When I look at it in ControlCenter, it tells me the license is ok.

Background:
A few months ago, I went to upgrade to Nero 2019 in hopes it would save to .mov file format (it doesn't), but the cost was prohibitive for a lifetime license (I only use the product on average less than once per year). So I checked ebay for a used copy and obtained one, which worked for a few months, but is now listed as non-licensed use in ControlCenter. I suspect I was scammed. If that is the case, I would like to start using my Nero 11 again, but it won't launch.

I can't contact Nero because their contact page with a form just loads a blank web page (in Chrome, Firefox and Edge).

Perhaps installing Platinum 2019 clobbered something in Nero 11? Or...?

I just re-installed Nero 11, and get the same result. Or can Nero staff tell me if my Platinum serial number is valid and get it running again?
1 person has
this question
+1
Reply