Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

Mediahome Won't Play Commercial DVD

I received a CD with Nero2014 Essentials as part of my purchase of a Memorex DVD/CD writer. I installed it completely and followed all the instructions. Then when I put a commercial DVD in the player, the only option to play it was through Nero Mediahome. Mediahome refused to play the DVD. When I selected the film and hit the play button, absolutely nothing would happen. No error messages, no sound from the DVD writer - there was nothing. I tried every way to hit a play button that I could and Mediahome was completely unresponsive to all of them. What do I do? I've tried restarting my laptop, downloading the free version of Mediahome from your website (which then couldn't even play DVDs), and uninstalling/reinstalling the software from the CD. Nothing is working! I think my software is faulty. I know that the disk reader is not the problem, because it has installed other software perfectly. Nero is the issue.
1 person has
this problem
+1
Reply