Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

Nero Video and Recode on 2017 and 2018 doesn't work

I have been running Nero 2014 Platinum on my AMD computer with no problems, even through changes in OS from XP to Windows 7 to Windows 10 and a change of motherboard and graphics card.Nothing phased it. I have had none of the problems some others have had until I bought Nero 2017 and 18.
Before installing Nero 2017 I read the Q&A about "Can I install Nero 2017 with my old version or do I have to remove it first?"' The answer was both can co-exist fine.
So I installed Nero 2017. At first it seemed to be OK. When I loaded a file into Nero Video it edited OK. When I tried to export the file Nero just froze. I went back to the editing screen and clicked NEXT then Export File and I managed to get to the next screen where I should have the options of file type etc to export as. The page had all fields blank. Contacted Nero Support who said I can't have Nero 2014 installed as well (but Nero 2014 was still working fine with 2017 installed. To keep them happy I uninstalled both versions and having received Nero 2018 Platinum I installed that. Same no go. Support said I have to enable Hardware acceleration - did that and made no difference, all fields still blank. Next it was suggested my drivers need updating - they were all up-to-date. Next it was my Winodws 10 was not up-to-date, but it was. Next it must be a corrupt Windows file, so I ran the checker through and it found No Errors. I kept telling them it is a conflict with AMD systems that the new versions are somehow different and therefore won't work. That was rubbished and I was even told that AMD and Intel chips are exactly the same just different brand names. Well shows how much they know. I asked them to explain to me WHY my old Nereo 2014 worked perfectly but 2017/18 won't. No response to my question. Then they send me a message saying I must have 'bought' a stolen licence off ebay or somewhere. DUH! I bought my Nero from them, how else would they know the licence key was registered to me? I really don't think they cared much about the problem because they ended support after accusing me of using a fake licence. Tried contacting them with my purchase receipt as requested but got no reply. Support ended because they don't have a clue why it doesn't work and burying their heads in the sand is easier than trying to fix the problem. I have read in the forum that others have had similar problems since version 2015, therefore Nero have known about the issue for at least 3 years and done nothing about it. I run a 6 core 3.3 GHZ AMD with 8GB RAM O/B video. I have tested the same version of NERO 2017 and 2018 on an old Celeron running Windows 7 - works fine. Tested it on an Intel i5 and it works perfectly. As far as I am concerned that proves that it is not a Windows issue nor a driver issue but an AMD issue. Whatever they have done to it since Nero 2014 has made it incompatible with AMD systems but they won't admit it and are no longer interested in the problem. And they wonder why so many people are unhappy with Nero.
2 people have
this problem
+1
Reply