I’m frustrated

several problems with nero 2014 platinum.

I have just successfully installed Nero 2014 platinum, and I already have several issues, I hope someone can help me, first problem : on Nero disc to device the buttons Browse, send, and cancel only show the top part of the letters, is there any way to change this, are there any settings that can help me change the view of the buttons?
second problem: on Nero media home, when I open this program I get this message
" You have connected a new device. to browse and access your photos, videos and music from your device on your pc you must switch it to mass storage mode." there is two buttons in the message window, Ok, and Cancel, again only the top part can be read, at the bottom of the window there is another message that says " refer to the device manual for how to do this" I had two external hard drives connected to my computer, no other device, I unplugged them and tried again, but the problem continues, I uninstalled the program I made sure that all my cell phones and tablets were not connected wirelessly to my computer, and installed the program again, still the same problem but now I have pop us telling me that there is a problem with Nero media home it reads like this, " Nero media home has stopped working, a problem caused the program to stop working correctly, windows will close the program and notify you if a solution is available" windows never came up with a solution, does any one have any Ideas of what the problem might be?
Problem 3: Nero media browser, I have the same problem as Nero media home, I open the program I click in a video or photo, and get the pop up with the message,media browser has stopped working etc. again any Ideas what the problem is?
problem 4: The main reason I bought this software was cause my sister in law asked me to make some copies of her weeding video, while I was able to rip the video with the program, I was not able to play the original DVD on Nero BLUERAY player, I tried opening a folder in the program but it did not work either.
so I guess my question is, is the software that I receive FAULTY, and I need to send it back for a refund? or is this normal and there is a way to fix all this problems?
2 people have
this problem