Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Video blacks out after exporting

I've been having trouble with videos lately where it works fine when I'm watching the preview of what I've made, but then I upload the file and clips of the video will randomly black out while the audio still works.

I've done this multiple times but different parts of the video have this error, once it was 5 whole minutes with different clips that all blacked out.

I don't know why this is happening, I just need some clue as to why so I can try and fix it. I have a video that I worked really hard on that looks like crap cause of this error. I need help.
2 people have
this problem
+1
Reply
  • Hi, from the description I am not sure what you are doing. I assume you edit a video in Nero Video 2018, export it as file and upload it to YouTube. Right? If so, is there already black if you play the exported file locally on your PC?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Yeah the black parts of the video appear before I add it to youtube (when I play it locally), it's just that a lot of times I don't want to tinker with a video for weeks so I end up uploading it to youtube anyway and just hope people wont notice the glitches.

    I have a lot of video files in the editor (or at least a lot of small clip segments), I've been thinking that might be the reason its doing that, but that's only a guess.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • One of the key questions in Since5.5's answer is, are you exporting it to file and does the exported file play correctly? The other question is, are you using Nero Video 2018?

    What is the format of the videos that are black? Is it possible that these are copy protected?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • I'm exporting it to file, and different parts of the video black out. So sometimes I'll do an export and some of the gameplay footage will black out, other times its my animated avatar.

    I am using Nero Video 2018 yeah.

    I don't think copy protection is the issue because some of the video I create is made by me in Flash; so I doubt that's the issue.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Question is- does the same video always come out black or is it random?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Did you want the file that shows all the various clips and how its edited (the raw file) or the finished video with the glitches (as the raw file might help reveal what I'm doing wrong, but the glitch is only present in the exported version).

    Anyway, here's a link to the exported file, the animated avatar in the bottom left corner is the part that sometimes blacks out (thankfully the main video doesn't black out anymore, but it was before).

    https://www.dropbox.com/s/tx4pga8xln3...

    Also it seems to be random, as I exported it about three times, and different parts the video blacked out each time; there seemed to be no reason to it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • There is a problem for some people when they export to mpeg-4 in v2018. However, I think the problem is that it won't finish exporting. I didn't look for the thread (s). However, I think that Nero is working on it. You can run it past tech support in case someone else has had the same experience.

    I don't know the resolution of all your original files. It looks like some of the video is low resolution yet you're creating a 1440x resolution file. It might be better to export it at 720p. Could be a possible cause of the occasional black out.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • I actually turned the bit rate and resolution down on this latest version and it seemed to reduce the "black outs" somewhat.

    What would be the approx resolution for 720p if you don't mind me asking (I'm not much of a graphics buff).
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • The resolution would be about 720 x 480.

    The maximum bit rate for DVD-Video is 11 KBPS, including the audio. The maximum bit rate for the video would be 8 KBPS.

    When you adjusted your settings, was there any improvement when viewing the video? The low resolution stuff was on the verge of extreme pixilation when I looked at the file you provided.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Ah, I had it set a bit higher than that; I'll have to try lowering it and see if that does anything.

    Well it was an 8 bit styled game, you sure that wasn't intended? Otherwise I didn't see any dramatic drops in video quality, once it has a chance to properly load in that is.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I think the 8 bit you're referring to is for the color graphics. It has nothing to do with frame rate. When one tries to encode low resolution graphics to a higher bit rate, unwanted things, like pixelation, may occur.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Ah ok, well still it gives me an idea of what to attempt now. Though there's still a possibility the screen will continue to black out just because of how many video segments I use in the animated avatar Icons. I'm going to try and consolidate that a bit too, see if that helps.
    • view 2 more comments
    • Thanks. I understood what you were doing.

      A single clip is a title if you start Nero Video and select one of the disc projects such as DVD, DVD-Video. If you add more clips in that scenario and don't Join them, then you will be limited to 99 in DVD-Video. If you use Make Advanced Movie, clips are automatically joined to make one title.

      Have you tried exporting the project at 720x... since we talked yesterday?
    • I tried it this morning; it started out working well enough but then after about the half way mark the error started appearing again. I'm glad I know now how to alter the settings at least. I didn't realize it was set to HD by default.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Joseph,

    I've reviewed this topic and find very little information that would allow others to replicate the issue. Source file details? Sample copies of your source files? Etc.

    I've created a project using Nero 2018 Video. Here is a screenshot of the timeline:



    Here's a YouTube video showing minimum source file data and the edited video:



    To post even more data about your source files, see Use MediaInfo in Your Browser.

    I've exported this project as AVC with and without hardware acceleration and as MPEG-4. All were fine and are available at this llink:.

    My source files and results.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Also here's what my timeline looks like (a small part of it). Many of these clips are just repeats of each other. There definitely is less than 99 source videos used in the library, but the number of edited segments of those videos (and still pictures) in the timeline would definitely exceed 99.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Here's a screenshot of the MetaData of the avatar clips. Please keep in mind that at the time I only knew of one converter that I could use (swivel) and I was recommended by one of Nero's employees (in a separate help support thread from this one) a program called "handbrake" that I have yet to implement.

    • view 4 more comments
    • Joseph,

      The new video appears to be an avatar from track 2 (video 2), not video 1. Incidentally, there are PNG picture files and MP4 video on track 1. Have you noticed where the avatar goes black or if it matters?

      I didn't know that you were working with Tech Support, so I'll back off. But, in any case, it would help to have a repeatable, SIMPLE, case that demonstrates the failure.

      Here's the sort of thing I've done (without any problems):



      And, here's the result:

    • Tech support was responding to a query on a separate area (the tech support session rather than this forum here).

      It seems to go black randomly, and its in different sections every-time the video is uploaded; so I agree its hard to replicate the results because I'm not sure exactly what's causing it.

      I think though in order to replicate the results effectively you'd need to have a long video (30 mins +) with lots of clips in order to see the black out occur; however, please don't attempt that as it would be a lot of work and I don't want you to become frustrated and you've already helped a bunch already.

      I want to thank you and "wither" for all the advice and help both of you have provided. I've learned much more about Nero than I did before, and although I may still have the problem I now have more tools to potentially figure out a solution.

      If you have any other suggestions I'd be happy to try them, but this might be one of those things where I might have to manually retool my avatar files to be smaller resolution and use a lot less edits so the program doesn't have as much trouble uploading them.

      I might even try uploading the video in shorter segments and then stitching them together and see if that does it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • I notice that you have some very short breaks periodically between the avatars. Depending on the point these appear in the photographs, you might be seeing black because of that. From what I can see, it looks like the breaks are 2 seconds or less.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated

  • If that were the case I'd think the black spots would appear in the same places; but they don't, instead they seem to occur randomly. Unless this is a bug that occurs with Nero when you try and have too many breaks in the clips?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • I agree.

    In the screenshot from 19 hours ago, there's also something that I don't understand. The duration of your avatar is 4 seconds, yet, at a location such as 3 minutes, there is a blank area after 4 seconds and the audio for the avatar is extended under that. I'm unable to reproduce that. Maybe you can explain how you did that. I don't know if that would affect encoding.
    • view 8 more comments
    • Possibly, its hard to say; the problem is that I only started making videos very recently (this is my 3rd video), so its not as though I had no problems before and then started encountering them randomly.

      Omega has shown that with a method very similar to mine he can produce a stable video of 10 minutes, so perhaps I need to export my video in segments, then re-import the results in a new project once they've been "stitched" together and see if that fixes it. I'll probably try this tomorrow. I've just been trying to get some rendering done meanwhile.
    • Ok, so I tried breaking the video into three parts of 11 mins or less each and uploading them, but the glitch reappeared about half way through (frustratingly so). My last theory is that some of the shorter avatar clips I was using (the ones you mentioned that are less than 2 seconds) may be causing the glitch to occur (they are separate files by the way, not just the longer one cut into small sections). So I'm going to see if Omega will run one more test for me, see if he sees the glitch. If not I'm going to give up for now and try again later. Thanks for all your help though.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Screen-capture of the metadata for "video 1", usually video captures from either windows recorder; or "GeForces" "Shadowplay". In some places I use a still picture though (like the snapshot feature in Nero).

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Joseph,

    I've tried a 10 minute project after creating a video that closely matches your data above, 1920x1016, 29.97 fps, etc.



    Here's the avatar data (for completeness):



    Here's my Movie Options:



    Here's the procedure I used:



    Here's the export configuration:



    Here's the resulting video:



    Is my procedure similar to yours?
    • view 26 more comments
    • Joseph,

      If you use Private Mode, only you can see it - if you want to post a link, choose "Unlisted".
    • Ah ok, I'll switch it to unlisted then. It's still uploading, it will take about another hour. I think I'm going to run to town, do some errands, and link the result in an hour or so.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • First here's my video settings for the last test:



    Then how the timeline looks:



    Then finally my export settings:



    As far as I'm aware I have the settings as close to yours as possible; the only difference being I have more files/clips for the avatar talking (which I hope would be a minor difference).

    Here's approximately where I encountered glitches (I'll upload the Youtube video result when it's finished uploading in an hour or two).

    Before 7m (first one caught me off guard so I didn't get an exact stamp, was hoping it would work and not give me a glitch)

    8m 20s

    8m 40s

    9m 10s

    12m 10s

    12m 25s

    12m 54s

    26m 0s

    26m 24s

    To be even more throughout, I'm going to link a screen shot of a couple of those time stamps.

    They are as below:















    And like I said, once the youtube example is finished uploading I'll link that as well so you can double check my timestamps a bit and see what the error looks like. (That will take an hour or two to finish uploading).

    Thanks, let me know if you have any advice for further tweaking it see if we can figure out what's causing the problem.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Joseph,

    Please take a few minutes for a liitle experiment which could save a great deal of time if it works. I've zipped up a folder containing two Nero 2018 Video projects.. If you download it and unzip it, a folder will be created that contains the NVC files and the content. If you double-click one of the NVC files, Nero 2018 Video should open and complain about not being able to find the content. Follow the instructions and browse to the newly created folder, etc. Here's the idea:



    If the project opens normally, click "Save" to avoid the initial errors subsequently.

    P.S. I tried this long ago, but I don't think the user cooperated. If it doesn't work, please post what happens. If it does work, all happiness will ensue!
    • view 5 more comments
    • Hey sorry for the delay, got caught up in errands with the start of the month and the holiday and all.

      So I exported the file with the same settings as before and I encountered the black out glitch but only about 4 times (at least that I noticed).

      Here's where they occurred:

      Around the 10 min mark (first one caught me off guard).

      17 mins, 20 secs

      17 mins, 40 secs

      18 mins, 40 secs.

      When you exported it on your side you encountered no glitches at all right (at least that your aware of). Would that mean there's something wrong with my version and/or hardware?

      Thanks, please let me know.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Joseph,

    I am quite certain that there were no black areas when I last exported the project. I did the entire process again. I've uploaded the result: ReExportOfALittleTest [1 GB]. I reviewed the result in Nero Video sped up by 10X and by 3X after scaling at 400 and positioning the avatar center screen as before.

    Also, I repeated the entire export without using Hardware Acceleration:



    No blackness.

    A few comments/questions

    I am using Nero 2018 Video on Windows 10 Pro. You?

    A major distinction between your project and mine is that my timeline was constructed by repeating a single 90 second segment. So, the encoding repeats time and time again.

    Since5.5 (Employee) expects a Nero 2017 Video update in a "days" and a Nero 2018 Video in "weeks" (see the last post in topic An error occured during the export).
    Now that you have my simple case that can be downloaded by anyone, perhaps Since5.5 (Employee) will try it? Or, maybe Nero would look into it:

    Support Issues

    Help with issues involving recent Nero versions can be obtained directly from Nero by using the email contact form at Technical Support via e-mail. This requires a valid product serial number which has the form XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX (8 groups of 4 characters/digits separated by dashes. Note: The serial number will not have the letter 'O'. Since this is a public forum, DO NOT post your serial number. If your serial number is not accepted, use the contact form at Nero Customer Service.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Alright so it must be some kinda problem on my side with the software or hardware then, if your doing the exact same thing with the exact same data and not getting a problem where I am getting a problem.

    I'm using Nero 2018 on Windows 10, yes.

    So how should I go about asking them for help, should I link back to this conversation/experiment we've had so they know what we've attempted troubleshooting wise and so I don't have to repeat it with them?

    Well I sent a support ticket to their official customer service; but they thought the error was due to my video being non compatible, I don't think they understood (or read closely enough) that the glitch was random, and that the icons are in a format that should be accepted by the program. They send me a converter, that while a useful tool, I don't think it's really what I need to fix my issue. The last response I told them was that I was trying to find the solution on the forums (what we were doing back and forth).

    Thanks Omega.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Joseph,

    I have now exported ALittleTest at high CPU priority with and without hardware acceleration. No black areas!

    I'll be out for a few hours. My system uses the internal Intel graphics. Yours?
    Did they ask you to send the NeroSupportTool output file?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Yeah weird, but at least we can rule out the CPU priority as a potential issue.

    I'll wait for your response when you get back, but how I can I tell how the system uses intel graphics? Is this like a video card setting?

    Also I sent them a lot of what I sent you, screen shots of my settings, a link to the video with the black outs time stamped (roughly).

    I am now waiting for their response.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • Joseph,





    On the one hand, I find it a little strange that Nero would suggest that your graphics device is incompatible without first asking what I have asked you (or after seeing the output of the NeroSupportTool program); on the other hand, considering my experience with them, it's not surprising!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned

  • To answer first question:

    Display adapter is "NVIDIA GeForce GTX 1070 Ti" (Maybe we've finally found the root of the problem).

    On the second thing.

    It's not that Nero thought my graphics device was incompatible, it's that they thought the avatar files were the wrong format. But if that was the case than none of the video for it would work, it wouldn't randomly black out, it would just fail to load or fail to display entirely.
    • view 22 more comments
    • Joseph,

      The YouTube video is not available Did you use the 'unlisted' setting or 'private'?

      As I mentioned above, Handbrake didn't work. Here's the free XMedia Recode.
    • Sorry I must have had it set wrong. It was on "Private", then I switched it to "unlisted" and now I can watch it on my alt browser (that's not logged into my Youtube).

      Try this: https://www.youtube.com/watch?v=Mz_5p...

      Alright, I guess I'll have to learn XMedia Recode. So all you did was just change the avatars from their default FPS to 30 FPS right?

      I'll probably see if i can fix my main project (the video game review) later this week. Maybe I'll show you the final result if you'd like, if you wanted to see what you helped me fix (would probably be more interesting than a 90 second flower loop, ha ha).

      Thanks again Omega.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • Joseph,

    I've reviewed your file twice after speeding it up 10X in Nero Video. I noticed one glitch. Here's the 10X:



    Here's the frame by frame of the original:



    So, what to do? Mulling over!
    • view 11 more comments
    • Joseph,

      Since Nero has shown absolutely no interest in your issue, it will only be fixed by accident! Over and out.
    • Understood, well maybe they'll fix it by accident later on. Anyway, thanks again Omega, appreciate all the advice and troubleshooting. See ya.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned